Black Screen - new user

View previous topic View next topic Go down

Black Screen - new user

Post  footagehead on Wed Feb 04, 2009 4:08 pm

Downloaded trial copy and test drive - everything tested and ran ok.
Looked in my iTunes folder and it showed the test file was there.
Also thumbnail preview of testfile.mov ran fine - video and audio.

Testfile was then shown on menu in both iTunes on my Intel iMac running Tiger 10.4.11, and on my TV screen, under ATV 2.3 'my movies'.
When I tried to run it I get audio only, no video.

Everything is synced, I see the logo of the video and Videodrive on the preview
screen of the TV in iTunes /my movies, it runs fine in quicktime on the iMac. Have rebooted, restarted, re-everything, several times.
All other vids that have been converted using iSquint, have played.
What have I missed ?
Thank you in advance for any help

Also - having problems using this forum on Safari 3.3 -had to switch to Firefox.

footagehead

Posts : 4
Join date : 2009-02-04

View user profile

Back to top Go down

Re: Black Screen - new user

Post  Aroona on Fri Feb 06, 2009 6:48 pm

Which import method did you use?
Which video format are you trying to play?
avatar
Aroona
Admin

Posts : 689
Join date : 2008-05-17

View user profile http://www.aroona.net

Back to top Go down

Black Screen - new user

Post  footagehead on Fri Feb 06, 2009 7:21 pm

Thanks your reply.

I checked 'copy vids into compatible containers."
in Preferences I checked "make vids compatible with enhanced ATV"
I also enabled 'hot folders'

I did notice it converting, but I'm not sure what it did.

The original file is an AVI. Now it's also Quicktime.

Having trouble using your forum with Safari 3.2 ..... not 3.3 my mistake. Must use Firefox

Thank you in advance

footagehead

Posts : 4
Join date : 2009-02-04

View user profile

Back to top Go down

Re: Black Screen - new user

Post  Aroona on Fri Feb 06, 2009 7:25 pm

Adding videos this way requires you to install additional codecs on ATV. Have you done this?

If the problem persists, this issue is most likely related to the codecs you have installed on your AppleTV. It is possible that some videos will cause unexpected behaviour and therefore you should discuss this with the developers of the codecs. Keep in mind that this scenario is not officially supported by Apple or ATV.

In that case, you should only have this issue with some videos. If you have the issue with all your videos, there might be some other problem.
avatar
Aroona
Admin

Posts : 689
Join date : 2008-05-17

View user profile http://www.aroona.net

Back to top Go down

Black Screen

Post  footagehead on Fri Feb 06, 2009 7:44 pm

Thanks - I may be too much of a total noob to use this, but my ATV 2.3 is a 'virgin' I have'nt done anything to it.
I thought that VideoDrive took care of just passing the content to the ATV from my iMac via iTunes without any hacks whatsover , i.e. Boxee, XBMC, etc.
I was hoping VideoDrive was a simpler way of avoiding all sorts of configuration bugs that these others seem to be having.

I have Perian 1.12 installed on my iMac, as 1.13 causes problems for Tiger users - my iChat did not work properly with 1.13.

Did I totally misunderstand your app ?

Thanks

footagehead

Posts : 4
Join date : 2009-02-04

View user profile

Back to top Go down

Re: Black Screen - new user

Post  Aroona on Fri Feb 06, 2009 7:51 pm

You have not misunderstood, but you should choose another import option. Choose the import method "Convert to apple TV" available on the main screen of VideoDrive. This will make your video compatible with AppleTV.

VideoDrive cannot do magic: if the device you play the video on does not support the format, the video will not play.

In the case of ATV, you can install Perian and then you can play your AVI files directly, when using the import options you have described before. Try installing Perian this way: http://www.iclarified.com/entry/index.php?enid=1959. This is off course at your own risk but is not very complicated.
avatar
Aroona
Admin

Posts : 689
Join date : 2008-05-17

View user profile http://www.aroona.net

Back to top Go down

Black Screen - new user

Post  footagehead on Fri Feb 06, 2009 8:15 pm

Thanks so much for being so responsive, and helpful.

So just changing the setting "Convert to Apple TV" is not all there is to it.

So if I get it, I must have Perian installed on the ATV via ATV USB creator, not just on my iMac....before the magic happens.

Your help is appreciated.

footagehead

Posts : 4
Join date : 2009-02-04

View user profile

Back to top Go down

Re: Black Screen - new user

Post  odiebold on Tue Apr 19, 2011 5:58 am

Hello

I am having the same issue here. I have imported some avi files using import method number 6 and the result is a black screen with sound and subtitles, both in iTunes and AppleTV.

I am using latest version of Videodrive, Perian 1.2.2.

I will try to downgrade to Perian 1.2.1 as that is the only thing that has been updated before this issue.

Thanks

Olivier


odiebold

Posts : 2
Join date : 2010-10-21

View user profile

Back to top Go down

Re: Black Screen - new user

Post  Aroona on Thu Apr 21, 2011 12:35 pm

Are you using QuickTime 7 or X as the conversion tool?
Did downgrading Perian help?
avatar
Aroona
Admin

Posts : 689
Join date : 2008-05-17

View user profile http://www.aroona.net

Back to top Go down

Re: Black Screen - new user

Post  odiebold on Sun May 01, 2011 2:00 am

Hello again

I am using QuickTime 7 for conversion. Downgrading Perian to 1.2.1 didn't help.

Any other suggestions

Thank you.


odiebold

Posts : 2
Join date : 2010-10-21

View user profile

Back to top Go down

Re: Black Screen - new user

Post  Aroona on Sun May 01, 2011 11:40 pm

If you take the original file and convert it with QuickTime 7 without using VideoDrive, do you have the same result?
If that's the case, there is an incompatibility between that particular video file and your codecs. If the problem does not occur, the issue is with VideoDrive.
avatar
Aroona
Admin

Posts : 689
Join date : 2008-05-17

View user profile http://www.aroona.net

Back to top Go down

Re: Black Screen - new user

Post  ingmar on Sat Jan 26, 2013 2:04 pm

Hi,

I just got VideoDrive yesterday (Version 2.6.09).

I guess my problem is the same as the one of the original poster of this thread. But since the thread is almost two years old I was wondering if maybe something has changes in the mean time.

I tried using Import option "2. Create reference files for your videos (default)". When I import an *avi, Quicktime 7 comes up for a second and disappears again. When I stream the video via Airplay on my ATV, I see a black screen and hear no sound.

I tried using Import option "3. Copy videos in a compatible container". When I import an *.avi, Quicktime 7 comes up and "flattens" the movie. This takes about a minute. When I stream the video via Airplay on my ATV, I see a black screen, and but I do hear the sound.

I finally tried using Import option "6. Convert to Apple TV and iPad optimized videos". The conversion takes places in Quicktime 7, but it does take a lot of time. However, streaming to my ATV works perfectly.

So, I guess, I do have to jailbreak ATV? Is that right? And will it be sufficient to jailbreak it? Or do I need to install additional software (drivers, codecs) in order to make internet videos in *.avi format run? Would be nice if you could give me a hint to the common software/products. Thanks guys!

Oh, I'm running OSX 10.8.2 Lion, I manually re-installed QuickTime 7, when VideoDrive setup asked if I would like to install Perian I agreed.

ingmar

Posts : 2
Join date : 2013-01-26

View user profile

Back to top Go down

Re: Black Screen - new user

Post  Aroona on Fri Feb 01, 2013 1:57 am

Hi,

1) If you use import methods 2-4:
Make sure Perian is installed (you can check this by clicking the Perian icon in System Preferences. If the icon is not there, you haven’t installed it yet).
If the video is playing fine in QuickTime 7, then VideoDrive should process it without a problem. Black screen or no sound is a typical problem if you don’t have the right codecs (such as Perian) installed.

2) If you use import methods 5-8:
I recommend selecting HandBrake on the Import tab of VideoDrive Preferences. This will speed up conversions. If HandBrake is not available, click the + button.

3) on AppeTV
If you have the black AppleTV, there’s no need to jailbreak it: use import methods 5 or 6, and you’re good to go.
Only the white AppleTV can be ‘jailbroken’ to sync/stream non-native video formats from iTunes.
avatar
Aroona
Admin

Posts : 689
Join date : 2008-05-17

View user profile http://www.aroona.net

Back to top Go down

Re: Black Screen - new user

Post  ingmar on Tue Feb 05, 2013 10:50 am

Hello Aroona,

thanks for your suggestions. But I guess I wasn't clear enough about my questions.

The only thing I am interested in is how to play internet movies (usually *.avi) on my Apple TV, 2nd generation. I don't want to watch them on my Mac.

Import methods 5 and 6 take a very long time for converting movies. So, I was wondering if a jailbreak and "some extra software" on the ATV would enable me to play movies via Airplay without the need of converting them to *.mp4. So, all I wanted to know is, if this is achievable at all.

Will FireCore's aTV Flash help in this scenario? In other words: I import my movies to iTunes with VideoDrive (using one of the fast methods, for example 2. Create reference files to your videos), and can then play my movies with AirPlay to my ATV (with aTV Flash on it). Does anybody have experience with this?

Thanks guys!

ingmar

Posts : 2
Join date : 2013-01-26

View user profile

Back to top Go down

Re: Black Screen - new user

Post  Aroona on Wed Feb 06, 2013 11:55 pm

We are following progress made in this field, but at the moment it seems that ATV will not play these videos, even after jailbreaking. It did work perfectly on the white AppleTV but not (yet) on the black AppleTV.

For a jailbroken white AppleTV, use import method 4. You can try this method if you have a second generation jailbroken black AppleTV, but our experiments failed.
avatar
Aroona
Admin

Posts : 689
Join date : 2008-05-17

View user profile http://www.aroona.net

Back to top Go down

Re: Black Screen - new user

Post  Sponsored content


Sponsored content


Back to top Go down

View previous topic View next topic Back to top

- Similar topics

 
Permissions in this forum:
You cannot reply to topics in this forum